Jump to content

David Hall

Hornbill Developer
  • Content Count

    513
  • Joined

  • Last visited

  • Days Won

    17

Everything posted by David Hall

  1. @Martyn Houghton Yes I totally agree it should be alphabetical, will raise a problem to have that addressed. Cheers, Dave.
  2. Hi @Joshua T M Unfortunately the flowcode we were discussing was related to historic imported updates which are a separate entity, not the request timeline updates as you highlighted in the last post. For the timeline we store an activity id against each request and then use that id with the activity -> activityStreamQuery api to return content. Just to step back a bit, if you can give me an idea of what you are trying to achieve we can see if there is a simpler way to do it? Regards, Dave.
  3. Hi @IntegraGreg The scenario you outline would work if "Date Logged" was an available option, but currently we do not have that available for SLA rules. We already have a change request raised for adding further fields to enhance the flexibility of the rules based on the post below, so I will include your suggestion within the requirements for this change and add you as an interested contact so that you are notified when this is progressed. Kind Regards, Dave.
  4. @Joshua T M Yeah sorry about that, I've just updated the flowcode to include the relevant options going forward: * resultType - 'count' or 'allData' * returnPrivate - 'true' or 'false' * updateOrder - 'ASC' or 'DESC' If there are any others that are unclear just let me know Cheers, Dave
  5. Hi @Joshua T M Apologies, I missed the notifications Not entirely sure why, but this is essentially a boolean implemented as string, so you need to pass "true" or "false". Will again update that description accordingly. Kind Regards, Dave
  6. Hi @Ann-MarieJones The content of the notification emails are all stored in templates which you can edit as you require. If you take a look at the section titled "Email Notification Templates" on this page https://wiki.hornbill.com/index.php/Service_Manager_Notification_Settings you will see a list of the template names for the various types of notifications. From within the admin portal, if you navigate to Home > System > Email > Tempates you will see the templates listed and you can update the link and any content as needed. Hope that helps, Kind Regards,
  7. Hi @chriscorcoran No there haven't been any recent changes. The tab will only show if you have more than one service level configured. Kind Regards, Dave.
  8. @Martyn Houghton thanks for the update, glad that you have the options showing again. Looking at the code it will probably show the options in the order they are found in the list of connections, but I will have to confirm that. Cheers, Dave.
  9. Hi @Martyn Houghton Just a quick update. I managed to replicate 2 cases where the connection list options may not be displayed at all and I have added fixes for these. A new update has just gone out but unfortunately these fixes could not be added in time so these will be in the following update. I've retested on the latest code and could not find any further issues after an initial caching issue. Perhaps you could confirm if the latest update of service manager happens to make any difference to this issue, if not then I'm happy to have a look on your instance either now or after the
  10. Hi @Blowerl Thanks for the post. Apologies for the inconvenience. We've addressed the issue and the fix is now in testing ahead of the next Service Manager update which will resolve this issue. Kind Regards, Dave.
  11. Morning @Martyn Houghton Thanks for the offer but I've managed to replicate the issue locally so hopefully I can debug it from here. Strangely if I see it fail and not show any connection options, opening the browser console and then trying again and it appears to work, so just trying to identify what is causing the problem as the code appears to do what it should. Will keep you updated. Kind Regards, Dave
  12. Hi @Martyn Houghton Thanks for the update, I'm continuing to try to replicate and diagnose, will feed back as soon I make any progress. Kind Regards, Dave
  13. Hi @Martyn Houghton I've been trying this locally and it did appear that I was seeing some caching issue that I could not diagnose and then it went away. Just to investigate further, if you change the connection type on any of the connections, or if you add or remove a connection, does this have any impact on the options shown to you in the email action? Regards, Dave.
  14. Hi @JO_7001, To remove the checkpoints altogether you will need to click the pencil icon and then delete the relevant stage checkpoints from the list as shown in the screenshot. Hope that helps, Kind Regards, Dave.
  15. Hi @Joshua T M Thanks for the post, to invoke that API call you will need to supply getRequestHistoricUpdates for the queryName parameter and this should enable it to complete successfully. This should have been made clear in the parameter description so I'll see about getting that added in now for future reference. Kind Regards, Dave.
  16. Hi @Ann-MarieJones Thanks for the post. It looks like you are not currently using the latest service manager update, as standard I would advise updating to the latest version and seeing whether that corrects your issue or not. There have been changes made to this suspendOwner operation in the latest update so if you could update and then let us know if you still receive errors we can investigate further from there. Kind Regards, Dave.
  17. Hi @samwoo Yes that's correct, provided the request is logged from within the main app (i.e. not via email or the portals) and you are not a member of the team the request is being assigned to then you will be added as a member which will let them view a request as if they were part of the team. Regards, Dave.
  18. Hi @Aaron Summers Just to follow up on this, we've identified the issue and we'll have a fix included for our next update. Regards, Dave.
  19. Hi @Aaron Summers Thanks for the post, it does indeed look like something a bit odd is going on with the paging in this view, I'll get a problem raised and we'll investigate further. Kind Regards, Dave.
  20. Hi Geoff, Yes as long as it is after your "Wait for Incident Priority" node then it should match the rules correctly. Regards, Dave
  21. Hi Geoff, Sorry about the back and forth, can I confirm if in this case you are making selecting a priority mandatory as part of logging the request or are you manually setting the priority within the request details after it has been logged? From the screenshots you have provided the service level configuration looks correct, but it would appear that the "Start Resolution Timer" BPM node is being called before the priority is set on the request, if this is the case then I would check that I have a "Suspend -> Wait for Request Priority" node in my BPM process before the "Start R
  22. Hi Geoff, Would you be able to show me one of the rules you have created that is failing just so I have an idea of what you have configured? Many thanks, Dave.
  23. Hi Geoff, So just to confirm, before the above BPM node is hit, you have already set a priority e.g. by selection during your logging process or by using the "Suspend Wait for Priority" BPM node? Maybe worth just showing me the details from one of those rules that is not being met as well. Dave
  24. Hi Geoff, So the only way you should end up with the "Initial Service Level" is if none of the previous rules are matched. So at the point of the BPM where you have used the "Start Resolve Timer" task, is the priority value you are checking correctly set to match one of the rules? Just as a confirmation, currently this check is only done when that node is called to start the timers, if you subsequently change the priority etc it will not currently alter the chosen SL, this is coming out in our next update. Regards, Dave.
  25. HI Geoff Thanks for the post. I just wanted to check whether you had configured the rules that determine which SL should be picked up by the request? If not then there are details here https://wiki.hornbill.com/index.php/Service_Level_Rules_Builder on how to do this. If you have configured the rules but are still having problems then let me know. Kind Regards, Dave.
×
×
  • Create New...