Jump to content

David Hall

Hornbill Developer
  • Posts

    557
  • Joined

  • Last visited

  • Days Won

    19

Posts posted by David Hall

  1. Hi @Martyn Houghton

    Just a quick update.  I managed to replicate 2 cases where the connection list options may not be displayed at all and I have added fixes for these.  A new update has just gone out but unfortunately these fixes could not be added in time so these will be in the following update.  I've retested on the latest code and could not find any further issues after an initial caching issue.  Perhaps you could confirm if the latest update of service manager happens to make any difference to this issue, if not then I'm happy to have a look on your instance either now or after the next update with the 2 fixes has been applied as you prefer.

    Kind Regards,

    Dave.

  2. Morning @Martyn Houghton

    Thanks for the offer but I've managed to replicate the issue locally so hopefully I can debug it from here.  Strangely if I see it fail and not show any connection options, opening the browser console and then trying again and it appears to work, so just trying to identify what is causing the problem as the code appears to do what it should.

    Will keep you updated.

    Kind Regards,

    Dave

  3. Hi @Ann-MarieJones

    Thanks for the post.  It looks like you are not currently using the latest service manager update, as standard I would advise updating to the latest version and seeing whether that corrects your issue or not.  There have been changes made to this suspendOwner operation in the latest update so if you could update and then let us know if you still receive errors we can investigate further from there.

    Kind Regards,

    Dave.

  4. Hi Geoff,

    Sorry about the back and forth, can I confirm if in this case you are making selecting a priority mandatory as part of logging the request or are you manually setting the priority within the request details after it has been logged?

    From the screenshots you have provided the service level configuration looks correct,  but it would appear  that the "Start Resolution Timer" BPM node is being called before the priority is set on the request, if this is the case then I would check that I have a "Suspend -> Wait for Request Priority" node in my BPM process before the "Start Resolution Timer" node.  This new node would ensure that the BPM waits until you have selected a priority, details can be found here https://wiki.hornbill.com/index.php/Service_Manager_Business_Process_Workflow under the "Suspend" header where there is an entry for "Wait for Request Priority"

    Regards,

    Dave

  5. Hi Geoff,

    So the only way you should end up with the "Initial Service Level" is if none of the previous rules are matched.  So at the point of the BPM where you have used the "Start Resolve Timer" task, is the priority value you are checking correctly set to match one of the rules?

    Just as a confirmation, currently this check is only done when that node is called to start the timers, if you subsequently change the priority etc it will not currently alter the chosen SL, this is coming out in our next update.

    Regards,

    Dave.

  6. HI Geoff

    Thanks for the post.  I just wanted to check whether you had configured the rules that determine which SL should be picked up by the request?

    If not then there are details here https://wiki.hornbill.com/index.php/Service_Level_Rules_Builder on how to do this.  If you have configured the rules but are still having problems then let me know.

    Kind Regards,

    Dave.

  7. Hi @RobW

    Thanks for the post.

    From the screenshot I'm wondering if you are looking at a "Corporate" service level but opened from within a service?

    If you have opened up the form from within the service view then you can only edit "Service Specific" SLAs, if you wanted to update the "Corporate" (shared) SLA then you would need to do it from the main service portfolio view and click on the "Service Level Agreements" tab.

    Hope that solves your problem... if not then let me know.

    Kind Regards,

    Dave

     

    image.png

    • Thanks 1
×
×
  • Create New...